Arquivo da tag: Ubuntu

[Atualizado] Instalação da última versão estável do Ansible no Ubuntu 15.04

Ansible logoEm uma definição minimalista e até injusta, Ansible é uma ferramenta para automatização de tarefas em servidores remotos. Há alguns anos eu sugeri um script para execução de tarefas remotas via SSH e que me atendia bem até que a pouco mais de um ano, naquele mesmo post um visitante me sugeriu conhecer o Ansible que logo no primeiro contato achei incrível. Continue lendo [Atualizado] Instalação da última versão estável do Ansible no Ubuntu 15.04

GetJava – Obtenha o Oracle Java 8 para seu Debian / Ubuntu

Java-LogoJá se foram quase 3 anos que disponibilizei o “getjava”, uma ferramenta que criei para facilitar a minha vida na aurora do Linux, uma época em que tudo era mais difícil. A ferramenta ficou engavetada por muito tempo até que a Oracle decidiu mudar a politica de distribuição e então a resgatei, dei uma repaginada, coloquei no Github e pronto. Passei a manter atualizações periódicas dela.

Nesta última atualização que disponibilizei hoje, é possível instalar praticamente qualquer versão do JRE com apenas um comando. Se você está de saco cheio com as incompatibilidade do OpenJDK e outras alternativas livres que por melhores que sejam o impedem de acessar determinados sites, acesse o último release no Github e seja feliz.

Problemas com driver WIFI Broadcom BCM4313

Há algum tempo tenho usado o Ubuntu 14.04 em meu netbook e tudo funcionava muito bem até que recentemente fiz algumas atualizações e após isso, estranhamente, embora o indicador de intensidade indicasse que o sinal estava excelente e todas as ferramentas de gerenciamento de conexão indicassem que eu tinha um endereço IP, rota, DNS etc, eu simplesmente não conseguia acessar a minha rede doméstica. A culpa era o driver da Broadcom, foi só removê-lo e pronto.
Continue lendo Problemas com driver WIFI Broadcom BCM4313

Erro no cache do APT

Recentemente tentei fazer uma atualização de pacotes no meu sistema pela linha de comandos e ao final do processo de upgrade recebi a seguinte mensagem:

dpkg: error: parsing file '/var/lib/dpkg/available' near line 2594 package 'libeina1':
 package has field 'Multi-Arch: same' but is missing architecture

A atualização ocorreu aparentemente bem no entanto as tentativas de instalar outros pacotes posterior a isso eram interrompidas e a mesma mensagem era exibida. A solução para o problema é dada com dois comandos apenas. Continue lendo Erro no cache do APT